Home > Ecommerce Shipping, Small Business Marketing > Stamps.com NOT AFFECTED by the Heartbleed Bug

Stamps.com NOT AFFECTED by the Heartbleed Bug

April 14th, 2014

blog_heartbleed-247x300Last week (April 7, 2014) a serious security vulnerability called Heartbleed (http://heartbleed.com) was announced regarding OpenSSL which is software widely used to support secure Internet services.

In response to notification of the vulnerability, Stamps.com reviewed all of our sites and applications and found NONE of our systems are vulnerable to this security issue.

Very few of our sites use the OpenSSL software and those that do are not running versions of the software vulnerable to Heartbleed.

Need more info? Get it at http://heartbleed.com/

Comments are closed.

Call us toll-free at 1-888-434-0055, Monday - Friday, 6 AM - 6 PM Pacific Time.